How to fix an non-responsive event in eValid

General discussion about eValid, its characteristis and applications.

How to fix an non-responsive event in eValid

Postby KatieW » Mon Apr 20, 2020 12:16 pm

Good afternoon.

What do I do if I send an event by eValid and nothing happens?

Any tricks on how to overcome this issue would be helpful.

Thanks
KatieW
 
Posts: 1
Joined: Mon Apr 20, 2020 12:11 pm

Re: How to fix an non-responsive event in eValid

Postby eValid » Tue Apr 21, 2020 9:40 am

KatieW wrote:Good afternoon.

What do I do if I send an event by eValid and nothing happens?

Any tricks on how to overcome this issue would be helpful.

Thanks


Thanks for posting KatieW.

The way you can trigger an event in eValid is to use the IndexElementEvent command.

This command triggers an event at a particular DOM index, and on a particular property name which as a particular property value (this distinguishes when there are multiple instances of the name, but only one with the specific value).

If this doesn't fire the event (trigger the event) then you have sent the trigger to the wrong element/property/value combination.

To "debug" this, you use the PageMap feature to see if you can find the error, described here:

http://www.e-valid.com/Products/Documen ... p.gui.html

The most common mistake here is that the actual DOM index changes because some active JavaScript has moved things around.

Let us know if you can't resolve this.


-- eValid Support
eValid
 
Posts: 2034
Joined: Tue Jan 01, 2008 12:48 pm
Location: USA


Return to General Solution Topics

Design Downloaded from free phpBB templates | free website templates | Free Web Buttons